Welcome, Guest
Username: Password: Remember me

TOPIC:

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 03:50 #897830

  • Wookie58
  • Wookie58's Avatar
  • Away
  • Moderator
  • Posts: 3325
  • Thank you received: 1885
Hi Rolf, regardless of where you set the timing the "dwell" (coil recharge period) will be the same amount of crank rotation so no, it shouldn't give a problem with the coils
The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 04:09 #897831

  • Rolf1976_KZ900
  • Rolf1976_KZ900's Avatar Topic Author
  • Offline
  • User
  • Posts: 318
  • Thank you received: 127

Hi Rolf, regardless of where you set the timing the "dwell" (coil recharge period) will be the same amount of crank rotation so no, it shouldn't give a problem with the coils


Thanks  for explaining Wookie58.  I still dont understand why when setting the timing exactly at the advance mark (and the test bulb goes on). then the testbulb lights up 2-3mm after the F mark.
And when setting the timing so it is 2-3mm before advance mark the test bulb goes on exactly at the F mark. Must be something wrong with the dyna-s ?? Or is is maybe the something wrong with the distance the picupcoils is sitting on the timingplate to the rotor making them send signal for a too long period? or maybe this duna-s that was fitted to the bike before i bought it not was for kawasaki?

Well i will continue to run in the engine and see if it everything is okay and then if not  maybe buy a new dyna-s plate   or     start to try to install that boyer bransden kit that has coils included.  or     start making that coil relay mod

 

Please Log in or Create an account to join the conversation.

Last edit: by Rolf1976_KZ900.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 04:20 #897832

  • Rolf1976_KZ900
  • Rolf1976_KZ900's Avatar Topic Author
  • Offline
  • User
  • Posts: 318
  • Thank you received: 127
And my underside of the foot is hurting today after first drained the battery and then using the kickstarter about 150 times wearing sneakers
The following user(s) said Thank You: Wookie58

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 04:24 #897833

  • zed1015
  • zed1015's Avatar
  • Away
  • User
  • Posts: 2916
  • Thank you received: 1480

I still dont understand why when setting the timing exactly at the advance mark (and the test bulb goes on). then the testbulb lights up 2-3mm after the F mark.
And when setting the timing so it is 2-3mm before advance mark the test bulb goes on exactly at the F mark. Must be something wrong with the dyna-s ?? Or is is maybe the something wrong with the distance the picupcoils is sitting on the timingplate to the rotor making them send signal for a too long period? or maybe this duna-s that was fitted to the bike before i bought it not was for kawasaki?
 

As long as the timing is correct at full advance is what matters.
Wear in the advancer bob weights,stoppers or other factors can affect the difference in degrees between static timing and full advance so the static mark may not align exactly when full advance is set up correctly.
When setting the dyna i never use a test bulb but simply lay a spark plug attached to the appropriate lead on the head.
You will hear an audible tick when the plug fires which is more accurate than the bulb method.
I also don't spin the motor on the starter or kickstart but rotate the crank slowly with a 17mm spanner whilst holding the rotor fully clockwise with my fingers.

 
AIR CORRECTOR JETS FOR VM CARBS AND ETHANOL RESISTANT VITON CHOKE PLUNGER SEAL REPLACMENT FOR ALL CLASSIC AND MODERN MOTORCYCLE CARBURETTORS
kzrider.com/forum/23-for-sale/611992-air-corrector-jets-





The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Last edit: by zed1015.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 04:42 #897834

  • Rolf1976_KZ900
  • Rolf1976_KZ900's Avatar Topic Author
  • Offline
  • User
  • Posts: 318
  • Thank you received: 127
Thanks for reply .I did first not use the testbulb i could hear the spark ticking inside the cylinders with the plugs mounted and turning the crank with the 17mm spanner ,but i desided to use a testbulb after that to be sure.
So now the timing is not correct it is correct at the F mark ,but it is firing the plugs about 3mm before the advance mark .That is how it is now and the bike runs and starts okay.
When i try to set it to fire exactly at the advance mark the bike will not start only with starterfluid. so maybe the dyna-s is broken?

A little video capture from yesterday first testride. I tried to make a first startup video ,but it did not start so that was a bummer =)

Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Rolf1976_KZ900.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 05:20 #897838

  • zed1015
  • zed1015's Avatar
  • Away
  • User
  • Posts: 2916
  • Thank you received: 1480
If it is sparking the dyna is not broken.
When setting the timing at full advance you are holding the rotor fully clockwise with your fingers as you rotate the crank aren't you ?.
That is the only way it can be done unless you use a strobe light..
AIR CORRECTOR JETS FOR VM CARBS AND ETHANOL RESISTANT VITON CHOKE PLUNGER SEAL REPLACMENT FOR ALL CLASSIC AND MODERN MOTORCYCLE CARBURETTORS
kzrider.com/forum/23-for-sale/611992-air-corrector-jets-





The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 05:24 #897839

  • Wookie58
  • Wookie58's Avatar
  • Away
  • Moderator
  • Posts: 3325
  • Thank you received: 1885
Bike looks really nice Rolf 
The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 05:27 #897840

  • Rolf1976_KZ900
  • Rolf1976_KZ900's Avatar Topic Author
  • Offline
  • User
  • Posts: 318
  • Thank you received: 127

If it is sparking the dyna is not broken.
When setting the timing at full advance you are holding the rotor fully clockwise with your fingers as you rotate the crank aren't you ?.
That is the only way it can be done unless you use a strobe light..


Yes that is how i do it .   I have bought a strobelight and planning to take a ride and check it with that .I have not used the strobelight before.
 

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 06:33 #897844

  • SWest
  • SWest's Avatar
  • Offline
  • Sustaining Member
  • 10 22 2014
  • Posts: 22495
  • Thank you received: 2643
Is the rotor sloppy? I'm now on my third one since 2014. Aluminum on steel isn't a good mix. Cost me $35 from Dyna. Mine was jumping back and forth at idle using the strobe light. All better now. 
Steve
www.dynaonline.com/
1 800 928 3962
The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 07:04 #897845

  • zed1015
  • zed1015's Avatar
  • Away
  • User
  • Posts: 2916
  • Thank you received: 1480


Yes that is how i do it .   I have bought a strobelight and planning to take a ride and check it with that .I have not used the strobelight before.

Can't see why it wouldn't start then with the timing correct at full advance.
The static would have to be miles out which isn't possible with normal wear unless you are mistaking the wrong mark for full advance.
A clear pic of the advancer etc may help..
AIR CORRECTOR JETS FOR VM CARBS AND ETHANOL RESISTANT VITON CHOKE PLUNGER SEAL REPLACMENT FOR ALL CLASSIC AND MODERN MOTORCYCLE CARBURETTORS
kzrider.com/forum/23-for-sale/611992-air-corrector-jets-





The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 19 Apr 2024 16:15 #897867

  • SWest
  • SWest's Avatar
  • Offline
  • Sustaining Member
  • 10 22 2014
  • Posts: 22495
  • Thank you received: 2643
I bought one of those cheap Dyna copies and the rotor magnet was 2* off so it was impossible to get it on time. I bought the Dyna rotor and now it's spot on. Dyna said the triggers are junk but they work for now. I'll install my Dyna plate to see if it still works. I'm thinking that may be your problem too. 
Steve
The following user(s) said Thank You: Rolf1976_KZ900

Please Log in or Create an account to join the conversation.

Need confirmation that timing is set wrong on my 1976 KZ900 20 Apr 2024 00:48 #897873

  • Rolf1976_KZ900
  • Rolf1976_KZ900's Avatar Topic Author
  • Offline
  • User
  • Posts: 318
  • Thank you received: 127

I bought one of those cheap Dyna copies and the rotor magnet was 2* off so it was impossible to get it on time. I bought the Dyna rotor and now it's spot on. Dyna said the triggers are junk but they work for now. I'll install my Dyna plate to see if it still works. I'm thinking that may be your problem too. 
Steve
 

            Yes i remember looking at some of your videos in the bike port tread earlier when you trying to set the timing.I think this bike has that cheap dyna installed so that may bee why it is difficult to get it right .I will check if the rotor is sloppy to. Thanks for information.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum